The API key provides a configuration file snippet with the connection information you need to connect to CSP Vault.

It may take up to 5 minutes for a new API key to become active on OCI. If you attempt to create your Cloud Service Provider account before the API key is active, it will fail with the "Failed to validate Access Credentials OCI returned" error.

To add an API Key for the OCI user

  1. In OCI, navigate to the user that you created.

  2. On the user page, under Resources in the left pane, click API Keys.

  3. Under API Keys, click Add API Key.

  4. Add the key using your preferred method.

    • Generate the key pair here and download the private key

    • Upload or paste your public key file

  5. Click Add. The Configuration file preview window will display the information that you will need to connect to CSP Vault.

  6. Click Copy to copy the file.